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Introduction: 
 
Interactive Physics™ 2000 is a powerful software package that allows teachers and 
students to simulate physical systems of many kinds. You can construct objects of 
various shapes, and adjust properties such as mass, coefficient of friction, initial 
velocity, material, elasticity, and charge. You can adjust the geometry of an object after it 
is created, as well as its appearance. You can measure position, velocity, acceleration, 
momentum, angular momentum, force, torque, gravitational force, electric force, air 
resistance, and kinetic energy. You can also define other quantities. You can control 
quantities in real time using sliders. You can write scripts that control a simulation. As 
you can see, Interactive Physics™ 2000 is not a package that can be completely mastered 
in an introductory session. However, this tutorial will give you a solid basis for a 
continued exploration of the breadth and power of Interactive Physics™ 2000. 
 

Tutorial: 
 
This tutorial is designed as a self-paced, hands-on introduction to Interactive Physics™ 
2000. The examples are selected from the Ontario secondary school physics curriculum, 
but are applicable to any introductory physics course. The tutorial assumes no previous 
experience with Interactive Physics™ 2000. However, should you already be familiar with 
certain features of the program, you may safely skip ahead until you find a topic of 
interest. 
 

Further Information: 
 
You can find further information, links to web sites of interest, and packaged simulations, 
many of which are freeware, at the following sites: 
 
http://www.interactivephysics.com/
 
http://ist-socrates.berkeley.edu:7521/projects/IPPS/Contents.html
 
http://www.scienceman.com/
 
http://www.enc.org/resources/records/full/0,1240,004489,00.shtm
 

Interactive Physics 2004 
 
As of this writing, a new version, Interactive Physics 2004, has been released. A 
demonstration copy may be downloaded from 
 
http://www.interactivephysics.com/

http://www.interactivephysics.com/
http://ist-socrates.berkeley.edu:7521/projects/IPPS/Contents.html
http://www.scienceman.com/
http://www.enc.org/resources/records/full/0,1240,004489,00.shtm
http://www.interactivephysics.com/


Getting Into the Swing: 
 
You will use the familiar pendulum as a 
vehicle for exploring the basics of IP 
2000. Launch the program. A blank 
workspace will appear. To make a 
pendulum, you will need a fixed point, a 
bob, and a string. Start with the bob. 
Select the Circle tool. Move to a 
convenient spot in the workspace, click 
and hold the left mouse button, and drag 
the mouse to form a circle of a
size. Release the mouse button. Selec
the Point Element. Move to a suitable 
location, and click the left mouse button
Select the Rope. Move the mouse to th
centre of the circle. Click and drag the
rope to the point. Release the mouse 
button. Your workspace will look 
like the screen shot at the right. 
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simulation. NOTE: If you are using
demo version of IP 2000, the Save 
function is disabled. Use the File pu
down menu, select Save As, navigate to a suitable directory, give your simulation a 
suitable name, and click Save. 
 
Click on the Run button. Your pendulum will swing. When you get tired of watching it go 
back and forth, click on the Stop button, and then the Reset button. This will return you 
to the initial conditions. 
 
IP 2000 can track objects as they move. Pull down the World menu and select Tracking, 
then Every frame. Run the 
simulation. Note that both 
the bob and the rope are 
tracked. Stop and Reset. 
You can erase the track by 
holding down the CTRL 
key and pressing the e 
key.  
 
Pull down the Window menu, and select Appearance. Click on the circle to select it. Turn 
off Track outline by clicking on the box. Turn on Track center of mass, as shown in the 
screen shot. Click on the rope, and turn off Track. Run the simulation again. Notice that 



this time only the centre of 
mass of the bob is being 
tracked. Turn off tracking 
from the World menu. 
 
Add a coordinate system to 
your model. Select the View 
menu, then Workspace. A
Rulers, Grid lines, and X,Y 
Axes, as shown. 

dd 

 
Move the origin to the 
middles of the workspace 
by adjusting the vertical 
and horizontal sliders. Move your bob to (0, -1), and move 
the fixed point to (0, 4). You may need to adjust the rope. 
You can also delete the rope, and redraw it. 
 
Now you will make some measurements. Select the circle. 
From the Measure menu, select Centre of Mass Position, 
and then X-Graph. Run the simulation. Note that the graph 
is generated as the pendulum swings. The scales on the 
graph are adjusted automatically to keep the position and 
time on the graph. You can also adjust these properties. 
 
From the Window menu, select Properties. Select the 
graph. The Auto feature enables the domain and range to 
adjust automatically if the body being measured moves 
outside the domain and range. If you turn the Auto feature 
off, the domain and range will remain fixed. 
 
Run the simulation through 
several cycles. You will 
generate a graph similar to 
the one shown. 
 
 
 
 
You can adjust the size of the graph by selecting it, and then dragging one of the black 
squares that appear in the corners. Adjust the graph to a convenient size. 
 



Now you will use IP 2000 to simulate an experiment which would be difficult to perform in 
the average classroom. You will 
try out the pendulum with 
varying gravitational 
accelerations. First, pull down 
the World menu and select 
Retain Meter Values. This will s
IP 2000 to display all runs on the 
same graph. Run the simu
for several cycles. Select Worl
then Gravity. Reset the 
gravitational acceleratio
value on the moon. Run the 
simulation. Then reset gravity to 
a value approximately d
that at the Earth's surface. Run 
the simulation. When finis
you will have a graph similar to 
that shown. You can use the gra
acceleration, and then fit an appropriate curve. It would be wise to obtain a few mo
points before doing this. 
 

et 

lation 
d, 

n to the 

ouble 

hed, 

ph to construct a table of period versus gravitational 
re data 

ou can Undo any operation by selecting Undo from the Edit menu, or by using the 
ould 

ou can investigate other factors that might affect the period of a pendulum, such as the 

. 
e 

eset the original mass of the bob, and erase the meter values. Select Air Resistance 

critical 

Y
keyboard shortcut CTRL-Z. This is useful if you encounter unexpected results, and w
like to retreat. You can usually retreat several steps in the simulation. 
 
Y
mass of the bob. Select Erase Meter Values from the World menu. Reset gravity to Earth 
normal. Run the simulation. Select the circle, and open the Properties box from the 
Window menu. Reset the mass of the bob to double its value, and run the simulation
Repeat for half the normal value of the mass. What effect does the mass of the bob hav
on the period of the pendulum? 
 
R
from the World menu. Select Standard, and run the simulation. Increase the air 
resistance, and run it again. Try to find the minimum value of "k" that results in 
damping, i.e., no oscillation. 
 



Rolling Right Along: 

Pin Joint 

Force 

 
Your second project will be a 
simulation of the classic 
Newton's Second Law 
experiment. Close the current 
simulation from the File menu, 
and then open a New simulation. 
Select the Rectangle, and 
construct a track across the 
middle of the workspace. Just 
for fun, run the simulation. 
Notice that gravity affects your 
track. Reset the simulation, 
select the Anchor, and attach it 
to the centre of mass of your 
rectangle track. This will stop 
your track from falling. 
 
You will now make a "cart". Start with a rectangle. Then create a circle for one of the 
wheels. Select the circle, select Copy and then Paste from the Edit menu. Position the 
body of the cart above the track, and the circles in position as wheels. Select the Pin 
Joint. Place a Pin Joint in the middle of each wheel. When you are finished, your 
workspace will look much like the screen shot. 
 
Now you will add a force controlled by a slider. 
Select the Force. Click on the centre of mass of the 
cart, and drag the force to form an arrow. Select the 
Force arrow. Open the Properties box from the 
Window menu. Change Fy to zero, if it is not zero 
already.  
 
From the Define menu, select New Control, then X 
Force. A slider will appear, which will allow you to 
control the force exerted on the cart. Select the slider. Change the minimum value to zero 
and the maximum to 10 N. Set the slider at 5 N, and run the simulation. Reset, and try 
other values, including zero. Note: You can also type a value directly in the box below the 
slider. 
 
Now you will measure the acceleration of the centre 
of mass of the cart. Select the cart. Select Center of 
Mass Acceleration from the Measure menu, and 
select All. A table will appear. Run the simulation. 
Note that the horizontal acceleration is measured. 
Due to the finite size of the intervals used by IP 2000, 
a small vertical acceleration is also shown.  



 
You can use this simulation to collect values of force versus acceleration. You can also 
leave the force constant, and create a slider to change the mass of the cart. Select the 
cart. Pull down the Define menu, select New Control, and then Mass. Select the new Mass 
control, open the Properties box if necessary, and adjust the minimum to 0.02 kg and the 
maximum to 5.0 kg. You can set the minimum to zero, if you like, just to see what will 
happen. This now allows you to simulate the standard Newton's Second Law experiment, 
a staple feature of all introductory physics courses. Note: It is not suggested that this be 
used in place of a hands-on experiment involving real carts and real forces. However, the 
simulation can be used as a review, or as a summative assessment tool. 
 
Add a little colour to your 
simulation. Select one of the 
wheels of the cart, and open 
the Appearance box under the 
Window menu. Change the fill 
colour and pattern to 
something that reflects your 
excellent taste. Do the same 
with the other wheel, the body 
of the cart, and the track. You 
can also adjust the colours of 
the sliders. Finally, you can 
adjust the background colour 
using the appropriate selection 
from the View menu. You can 
even define your own custom 
colour. 
 
Finally, add some text. Select 
the text tool in the toolbar. Click and drag to open a text box in the desired location. Type 
in the desired text. To change the font and style, pull down the Object menu, and select 
Font. Set the parameters to whatever you want. When you are finished, your simulation 
will look much more colourful. 
 



Sliding Down the Hill: 
 
IP 2000 includes friction in its calculations. To see how this works, you will simulate an 
object sliding down an inclined plane.  
 
You may work in either 
degrees or radians. To see 
the unit system in use, 
pull down the View menu, 
and select Numbers and 
Units. SI(degrees) will be 
used in this tutorial. 
 
Open a new workspace, if 
necessary, and use the 
Rectangle to draw a long, 
thin rectangle across the 
middle of the workspace to act as the inclined plane. Add an Anchor to its centre of 
mass. Construct a smaller thin rectangle over the centre of the inclined plane, such that 
their centres of mass are vertically aligned, as shown in the screen shot. 
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slider, and open the Properties box, if necessary. Change the 
minimum value to zero, and the maximum to 30º.  
 
Note the name of the slider. It will likely be Input[4]. Select the 
sliding rectangle. Change the initial angle θ to match the slider, 

e., Input[4] in this example. The slider will now control the i.
angle of the inclined plane as well as the sliding rectangle. 
Run the simulation, move the slider, and note the changes in 
the inclined plane and the sliding block. 
 
Run the simulation, and increase the angle of the inclined 
plane to 5º. Note that the block does not slide down the plane,
ince the force of friction between the blos ger than the component 

of the gravitational force acting down the plane. Increase th
increments of 5º until the block slides. Adjust the angle until yo
the block just begins to slide.  
 
You can also reset the incline of the plane on the fly. Reset the simulation with an angle 
of zero. Run the simulation. Slowly increase the incline angle using the slider until the 



block begins to slide down the plane, and then back off on the angle. Try to find the 

 
t key to select the ramp while 

eeping the block selected. Pull down the Measure menu, and select Friction Force. Run 
n. 

 

 the
omponent of Fg acting down the plane is Fg sin θ = 1.177 sin 15° = 0.305 N, as expected. 

ck. 

om the Window menu. Set the static and kinetic coefficients of friction to 0.500. Note: If 
e 

iction such that the force of friction 
xceeds the gravitational force on the block, and then Run the simulation. 

critical angle at which the block just begins to slide. 
 
Select the block. Pull down the Measure menu, and select Total Force. Pull down the
Measure menu and select Gravity Force. Use the Shif
k
the simulation, and find the slip angle as in the previous paragraph. Stop the simulatio
From the analysis of a block sliding down a plane, you know that, at this critical slip
angle, the component of gravity acting down the plane equals the frictional force. See if 
the simulation bears this out.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
In  screen shot, Fg = 1.177 N. Ffr = 0.305 N, and θ = 15°. According to theory, the 
c
 
You can investigate the effect of increasing the coefficient of friction. Select the blo
Hold down the Shift key to also select the ramp. If necessary, open the Properties box 
fr
two objects are in contact, and have different coefficients of friction, then IP 2000 will us
the lower of the two values to calculate the friction. 
 
Run the simulation and find the critical slip angle. Note that it is now much higher. An 
interesting extension is to adjust the coefficient of fr
e
 



Getting a Charge out of This: 
 
IP 2000 allows you to specify a charge for objects. You 
will investigate this using two spheres suspended by 
strings from a common point. Pull down the World 
menu, and select Electrostatics... . Select  the ON 
button, if it is not already selected.  
 
Select the Point Element, and create a point. Select the 
Circle, and create a circle below and to the left of your 
point. Copy the circle, and paste it to a corresponding 
location below and to the right of your point. Select the 
Rope. Join each of the circles to the point. When you 
are finished, your workspace should look much like 
the screen shot.  
 
Select the left circle, and select New Control from the Define menu. Select Charge. Select 
the new control, and note its name. It should be something like Input[10]. Change the 
minimum value to zero, and the maximum value to 0.0001 C.  
 
Select the right circle, and open the Properties box from the Window menu, if necessary. 
Change the charge property to the same input as the left circle. 
 
Set the slider near the middle of its range, and Run the simulation. Note that the circles 
bob up and down. To dampen this motion, select Air Resistance from the World menu, 
and set it to standard.  You may also need to change ‘k’ to something less than one.  Run 
the simulation. Adjust the slider on the fly, and note the effect on the position of the 
circles.  
 
Now add some 
measurements. Select 
the right circle. Use the 
Measure menu to 
create meters for 
Electrostatic Force, 
Gravity Force, and 
Total Force. Select the 
right rope, and create a 
meter to measure the 
Tension. 
 
Run the simulation, 
and allow the system 
to come to rest. 
According to the 
analysis for this 



experiment, the tension in the rope, the gravitational force, and the electrostatic force 
should satisfy a Pythagorean relationship. Check if they do. 
 
Moving Towards the Centre: 
 
IP 2000 allows you to represent gravity 
as a central force. This is useful for 
simulating the movements of heavenly 
bodies, escape velocity, and other 
phenomena that depend on the 
inverse-square nature of Newton's law 
of Universal Gravitation. You can change the scale of the workspace window in IP 2000 to 
reflect real distances, masses, and other parameters. You can do this by adjusting the 
View Size under the View menu, and object properties using the Properties box. For 
example, you can set the window to a real Earth-moon system, with distances and 
masses equivalent to the real Earth and moon. However, that means that you would have 
to wait 29+ days to see one orbit of the moon around the Earth. Although the View Size 
adjustment can be useful for making smaller scale simulations more realistic, 
astronomical phenomena are better simulated in a way that speeds up their apparent 
motions. 
 
Set up the Earth-moon 
system using two 
circles. Change the 
gravitational model to 
Planetary in the Gravity 
submenu under the 
World menu. Give the 
moon a suitable velocity, 
and Run the simulation. 
Unless you are very 
lucky, the moon will not 
follow a circular or even 
apparently elliptical 
orbit. It is necessary to 
scale the gravitational 
constant to match the 
scale of the workspace. 
With a workspace width 
of about 12 m, a 
gravitational constant of about 5 Nm2/kg2, and an initial moon velocity perpendicular to 
the radius of orbit, you will get something like the screen shot shown.  
 
Add a slider to control the initial velocity of the moon. Using the slider, try for a circular 
orbit. 
 



Notice that the Earth does not sit still. The Earth and the moon rotate around their 
common centre of mass. You can add a slider to control the mass of the Earth. Try orbits 
with a massive Earth, with an Earth mass equal to the moon's mass, and several in 
between, for a given initial velocity. Then, try a very light moon, and simulate the orbit of 
a comet. You might even add in a third or fourth body. The possibilities are endless. 
Investigations of Lagrangian or Trojan points can be simulated. 
 
You can also simulate the decaying orbit of a satellite by introducing air resistance. 
Track the object's path to view its orbital decay. 
 
The Monkey Bites the Dust: 
 
One of the most popular physics problems is the problem of the Monkey and the Hunter. 
A monkey is hanging from a branch on a tree. The hunter fires his gun, knowing that the 
monkey will let go of the branch and fall freely just as the bullet leaves the barrel. How 
should the hunter aim in order to hit the monkey? 
 
Use the Circle to create a "bullet". Select the bullet, and open the Properties box. Set the 
x and y coordinates to zero. This will ensure that the bullet begins at the origin. Use the 
workspace sliders to move the bullet near the lower left hand corner of the workspace. 
Use the Circle to create a "monkey" in the upper right hand corner of the workspace.  
 
You could use sliders to control Vx and Vy for the bullet, but it is more realistic to use 
sliders to control the speed |V| and the angle θ at which the bullet is fired. To do this, 
create two generic sliders using New Control under the Define menu. Select the first 
slider, open the Appearance box from the Window menu, and rename it Speed. Repeat 
this procedure to rename the second slider Angle. Also take note of their computational 
names, which will be something like Input[3] and Input[4]. Use the Properties box to 
change the limits on the Speed slider to cover the range 0 m/s to 20 m/s, and those on 
the Angle slider to cover 0º to 90º. 
 
Select the bullet, and open the Properties box, if necessary. Type in the following 
formulas: 
 
Vx:  Input[3]*cos(Input[4]*3.14159/180) 
 
Vy:  Input[3]*sin(Input[4]*3.14159/180) 
 
Note: Although you are setting the slider Angle 
in degrees, IP 2000 performs internal 
calculations in radians. Therefore, the angle 
must be converted to radians in the formula. 
 
This might be a good place learn how to insert 
a button. Select New Button from the Define 



menu, and then Menu Button. Select Autoerase Track. You can now erase tracks by 
pushing this button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Set the speed to 10 m/s, and pick an angle. Turn on tracking, and Run the simulation. If 
you didn't hit the monkey, pick another angle, and run the simulation. Once you find an 
angle that works, note it down.  
 
You can select another speed, and find the angle that works with that speed. Note any 
patterns that occur.  
 
Of course, you can cheat, and do the analysis first. In that case, you know that: 
 
tan

y
x

θ = , where x and y are the coordinates of the monkey. Select the monkey, note its 

coordinates, and check against the angle that you found empirically. 
 
A variation on this is to change the position of the monkey, rather than the speed of the 
bullet, and see what happens to the angle. 
 



Finally, you can make a prediction about the effect of air resistance. Check your 
prediction by adding in air resistance from the World menu. You can even change the 
amount of air resistance, and see what effect that has. 
 
Momentous and Energetic Thinking 
 
To finish off this introductory tutorial, you will simulate a one-dimensional elastic 
collision to investigate measurement of momentum, kinetic energy, and the export of 
data from IP 2000. 
 
Create a horizontal track, and anchor it to the background. Create a rectangular object on 
the left end of the track. Copy the object, and place the copy near the middle of the track. 
Select the left object, and create a meter to measure Momentum from the Measure menu. 
Do the same for the other object. Select the left object, and create a meter to measure 
translational Kinetic Energy. Do the same for the other object. When you are finished, 
your workspace will look much like that shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
From the Window menu, open the Properties window. Select the left object. Set the 
coefficients of static and kinetic friction to zero. Set the elasticity to 1, to simulate a 
perfectly elastic collision. Repeat for the other object, and the track. 
 
Run the simulation. Note the values of the momenta and kinetic energies as the 
collisions occurs. 
 
You can export data from IP2000 in two ways. Pull down the File menu, and select Export. 
A dialog box will appear. Pull down the Export Type menu. Note that you have a choice of 
exporting raw meter data, or video for Windows data. The former creates a tab-delimited 
text file, with the extension *.dta, which can be read into a word processor, spreadsheet, 
or many other programs. Once imported into another program, it can be manipulated into 
any kind of desired, graphs, tables, images, or other formats. 



An import of the raw data from the collision experiment into Microsoft® Excel is shown in 
this partial screen shot: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The second export option creates a standard *.avi file of the experiment, which can be 
played back using Windows Media Player, or other multimedia software. A user does not 
need to own IP2000 in order to view these *.avi files, making them useful for posting on a 
web site for student access. You can also convert the *.avi files to Shockwave *.swf files, 
which allow you to use streaming video. You can achieve this using a utility such as 
Camtasia, available at 
 
http://www.techsmith.com/products/studio/default.asp
 
This is a simple collision, involving two bodies of the same mass, a perfectly elastic 
collision, and no friction of any kind. You can introduce sliders to control the masses of 
the two objects. You can introduce sliders to control the coefficients of friction. You can 
introduce sliders to control the elasticities of the two bodies. Use what you have learned 
to extend this simulation to more interesting cases. 
 
The Next Steps: 
 
Interactive Physics includes many "canned" simulations, conveniently organized into 
topics by folder. Select Open from the File menu, and navigate to the directory containing 
IP2000. Select the folder Physics Experiments, and browse through the collection of 
simulations included.  
 
You can find an analysis, rating, and suggested uses for some of the experiments 
packaged with IP2000, prepared by Paul Passafiume, in Appendix A at the end of this 
tutorial. 

http://www.techsmith.com/products/studio/default.asp


There is a wealth of Interactive Physics support material available on the Internet. Type 
the keywords "interactive physics" into your favourite search engine, and you will find a 
plethora of sites, most with free downloads. To get you started, you can visit 
 
 
http://www.interactivephysics.com/
 
http://ist-socrates.berkeley.edu:7521/projects/IPPS/Contents.html
 
http://www.scienceman.com/
 
http://www.enc.org/resources/records/full/0,1240,004489,00.shtm
 
You can often download a simulation that is close to what you are looking for, and then 
make adjustments to suit your own needs. 
 
This completes your introductory tutorial. IP2000 has many more features for you to 
explore. This is only the beginning. 

http://www.interactivephysics.com/
http://ist-socrates.berkeley.edu:7521/projects/IPPS/Contents.html
http://www.scienceman.com/
http://www.enc.org/resources/records/full/0,1240,004489,00.shtm


 
 
by Paul Passafiume 
 
Here is an overview of several canned IP scripts available as part of the IP2000 software package.  These scripts can 
be found in the IP2000 folder that should be located on the C: drive following a standard install.  The following path 
should assist you in locating these files:  C:\Program Files\IP2000\PhysicsExperiments.  
 
The folder column below  indicates the folder in which the simulation may be found.  The program column indicates 
the program to which the script may apply (10 = grade 10; 3U = grade 11 physics; 4U = grade 12 physics).   
 
Note:  4 Star Rating given below is based on applicability to the high school curriculum. 
 

 Folder Program Overview of Folder Contents 4 Star 
Rating 

Advanced Other Simulations of gears, machines, and 
statics 

 

Cams Other 1 simulation  
Collisions 4U 13 simulations   
Electrostatics 4U 4 simulations  
Equilibrium 4U 4 simulations  
Evaporation/Condensation Other 3 simulations  
External Data 4U Shows how exp. data can be imported to 

IP for simulation purposes (1 simulation) 
 

Friction 4U 2 simulations  
Fun Stuff Other 4 simulations  
Kinematics 10/3U/4U 2 simulations  
Kinetic Theory of Gas Other 3 simulations  
Magnetics 4U 3 simulations  
Math Other 1 simulation 0 
Miscellaneous 3U/4U 15 simulations  
Momentum 4U 4 simulations  
Motion in One Dimension 10/3U 2 simulations  
Motion in Two Dimensions 4U 1 Simulation  
Newton’s Laws 4U 2 simulations  
Oscillations 4U 9 simulations  
Particle Dynamics 3U/4U 3 simulations  
Projectiles and Rockets 4U 4 simulations  
Pulley Systems 4U 2 simulations  
Rotational Dynamics 4U/Other 9 simulations  
Sound 3U 1 simulation  
Waves 3U 1 simulation  
Work and Energy 3U/4U 3 simulations  


